2014年03月21日

古いIEのみSSLサーバーからダウンロードできない

1日16時間の作業体勢に1週間ほど浸かっていたけど、やっと復帰。

色々あったけど、一番タチ悪かったのがこのバグで、IE7だかIE8の古いIEでのみ発生した物。

要は、これなんだけどね。
http://ml.php.gr.jp/pipermail/php-users/2003-October/019140.html

ダウンロードファイルを、phpアプリで直接生成して、echo で渡すと言う良くあるパターン。
発生するのはSSLサーバーで、セッション張っているケース。

対策は、session_start(); 前に、session_cache_limiter('public'); を発行するだけ。

再現環境が手元に無いから、いちいち対策らしいことをして、確認してもらっての繰り返し。
まあ、素直にGoogle先生に聞かなかった俺も悪いけどね。

posted by ゆるきま at 08:06| Comment(0) | 技術
この記事へのコメント
コメントを書く
お名前:

メールアドレス:

ホームページアドレス:

コメント: